別のJDKバージョンのMavenプロジェクトをコンパイルするには?

デフォルトでは、Maven 2はJDK 1.4を使用し、Maven 3はJDK 1.5を使用してプロジェクトをコンパイルします。これは非常に古いものです。幸いにも、Mavenにはhttp://maven.apache.org/plugins/maven-compiler-plugin/index.html[Compiler Plugin]が付属しています。これはMavenに特定のJDKバージョンのプロジェクトソースをコンパイルするよう指示します。

解決策

プラグインコンパイラを直接設定します。 (Maven 2と3でテスト済み)

pom.xml

<project>

  <build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.6.1</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
  </build>

</project>

あるいは、プロパティ値を使用して設定します。 (Maven 3でテスト済み)

pom.xml

<properties>
    <maven.compiler.target>1.6</maven.compiler.target>
    <maven.compiler.source>1.6</maven.compiler.source>
</properties>

参考文献

コンパイラプラグイン]。 link://maven/how-to-tell-maven-to-use-java-8/[Mavenに使用方法を教える方法

Java 8]